Can't read posts

Hi, I can see the Topics page fine, but when I try to open a post from one, all I get is one page of gibberish symbols. This applies to all posts I try opening.
Anything change? I am not aware of any changes on my end.

I had that happen this morning on my phone. Works fine now though.

I’ve had it come up numerous times since yesterday - in fact the thread “forums” deals with this exact topic.

How the heck did you manage to post this? Did you just guess where the post a reply might be?

Well, strangely enough, creating the post was no problem. However, when I then tried to read it, it looked just like all the others, garbage characters.
Looks like all is well now, though. Hopefully stays that way.

PS - I couldn’t read the “Forums” thread mentioned earlier, so that’s why I created this one. If the title had been more descriptive I wouldn’t have made my post.

Any of you people using Windows 10?? I had the same problem on my Windows 10 PC earlier today... so I booted up my Windows 7 PC, and was able to read the forum. The Windows 10 PC still had the issue while I was reading from the other PC. Came back tonight... and auto-magically... the forum displays just fine from my Windows 10 PC... I'm an IT guy... but I can't explain this one! :?

Happens randomly for random periods of time. Had it happen on an android phone, a Mac with both Chrome and Safari, and a Windows 7 machine running IE and Chrome. It's an equal opportunity glitch.

That's right, Win10, Android 5.11 with Chrome, Firefox, and the Samsung browser, OS/X Yosemite, etc...

Not using Windows 10 but have still had the problem off and on since Wednesday. Tried my android phone too when the gibberish showed up on the computer and it was there too. SO far today no problem - do hope it stays that way.